Krytyczna dziura w MSIE

W MSIE odkryto nową, krytyczną dziurę, która może służyć złośliwym stronom WWW do przejmowania kontroli nad przeglądarką użytkownika.

Dziura odkryta w we wszystkich stosowanych obecnie wersjach MSIE (5.01, 5.5, 6.x) jest związana z parsowaniem stron WWW zawierających formularze. Odpowiednia konstrukcja strony może prowadzić do nadpisania wewnętrznych struktur pamięci przeglądarki i wykonania złośliwego kodu na komputerze ofiary. W przeszłości tego typu błędy były powszechnie wykorzystywane do instalowania koni trojańskich, spyware i adware.

Problem został potwierdzony przez Microsoft (MSA 917077. Użytkownicy najnowszej bety Internet Explorera 7 nie są podatni na błąd. Firma pracuje nad poprawką dla starszych wersji MSIE.

Do czasu jej wypuszczenia Microsoft zaleca zastosowanie jednej z dwóch tymczasowych obejść problemu. Obydwa polegają na wyłączeniu Active Scripting, pierwsza jest łatwiejsza:

* włączenie "wysokiego" poziomu zabezpieczeń dla strefy Internet (Narzędzia->Opcje internetowe->Bezpieczeństwo, wybieramy Internet i ustawiamy suwak na Wysoki)

* wyłączenie tylko funkcji Active Scripting dla użytkowników, dla których tryb Wysoki jest kłopotliwy (jak wyżej ale zamiast suwaka wybieramy Poziom niestandardowy, dalej Ustawienia, sekcja Skrypty, w opcji Active Scripting wybieramy Wyłącz lub Pytaj)

Dołącz do dyskusji
Bądź pierwszy i zostaw komentarz.