Microsoft wymusi aktualizację Messengera

Przedstawiciele koncernu z Redmond poinformowali właśnie, że jeszcze w tym miesiącu firma zacznie zmuszać użytkowników Windows Messengera do uaktualnienia aplikacji do najnowszej wersji - 14.0.8089. Kto tego nie zrobi, ten nie będzie mógł korzystać z komunikatora internetowego Microsoftu.

Aktualizacji muszą dokonać użytkownicy wersji 8.1 i 8.5 - uaktualnienie jest niezbędne, ponieważ wykryto w nich niebezpieczny błąd, umożliwiający przestępcom przejęcie pełnej kontroli nad zaatakowanym systemem. Osobom korzystającym z tych wersji już od kilku dni wyświetlane są komunikaty o tym, że zalecana jest aktualizacja do najnowszego Messengera. Na razie zignorowanie ich nie ma żadnych konsekwencji - komunikator wciąż działa. Ale od połowy września za pośrednictwem wersji 8.1 i 8.5 nie da się korzystać z systemu komunikacyjnego Microsoftu.

Użytkownicy innych wydań WM również będą musieli przesiąść się na najnowszą wersję - ale w ich przypadku komunikat o konieczności zaktualizowania aplikacji do wydania 14.0.8089 pojawi się dopiero pod koniec października. "Cały proces aktualizowania komunikatora potrwa co najmniej kilka tygodni - będzie on przeprowadzany w kilku etapach" - czytamy w oficjalnym komunikacie Microsoftu. Koncern zaleca zresztą użytkownikom, by wcale nie czekali na alerty i komunikaty - najlepiej byłoby, gdyby osoby korzystające z Windows Messengera samodzielnie pobrały najnowszą wersję i zainstalowały ją w swoich systemach.

Messenger 14 to znaczące uaktualnienie komunikatora Microsoftu - program ma sporo nowych funkcji oraz zupełnie nowy interfejs. Ale aktualizacja jest niezbędna z innego powodu. Komunikator koncernu ma poważny błąd w zabezpieczeniach, który "odziedziczył" po luce w narzędziach developerskich Microsoftu - chodzi o wadliwą bibliotekę ATL (Active Template Library). W lipcu okazało się, że wszystkie aplikacje stworzone z jej wykorzystaniem mają ten sam błąd. Chodzi o literówkę w kodzie - dodanie zbędnego znaku "&". O problemie szerzej pisaliśmy w tekście "Poprawka dla ActiveX jeszcze dziś?".

Pod koniec lipca Microsoft udostępnił poprawki, usuwające tę lukę z zabezpieczeń Internet Explorera oraz Visual Studio. Kilka tygodni później były kolejne poprawki dla ATL - Microsoft załatał wtedy błędy w pięciu innych swoich produktach. Wtedy nie było wśród nich Windows Messenera - ale to żadne zaskoczenie, bo koncern od razu zastrzegał, że załatanie wszystkich luk związanych z błędem w ATL może potrwać wiele miesięcy. Poprawki dla komunikatora pojawiły się dopiero kilka dni temu. Koncern jest w tym przypadku dość stanowczy (co może świadczyć o tym, że luka jest naprawdę poważna) - a alercie napisano "Jeśli użytkownik nie zaakceptuje aktualizacji dla Windows Messengera, nie będzie mógł korzystać z usługi Windows Live Messenger" .

Co ciekawe, poprawka dla komunikatora nie będzie dystrybuowana standardowym kanałem Microsoftu - czyli za pośrednictwem systemu Microsoft Update. Koncern zamierza wykorzystać oddzielne narzędzie aktualizacyjne, stworzone właśnie z myślą o Messengerze. Warto dodać, że aktualizacja do wydania 14.0.8089 będzie obowiązkowa w przypadku użytkowników Windows XP, Server 2003, Visty, Server 2008 oraz Windows 7 (osoby korzystające ze starszych wersji mogą pozostać przy 8.1 lub 8.5).

Stanowczość Microsoftu nie do końca podoba się użytkowników - głównie dlatego, że wersja 14 nie wszystkim przypadła do gustu. "Czyli teraz chcecie nas zmusić do zainstalowania czegoś, z czego nie da się normalnie korzystać. Nie, dziękuję. Zostanę przy 8.5 - nie obchodzi mnie, jakie są tam błędy" - napisał ktoś w komentarzu do komunikatu Microsoftu. Inny internauta dodał: "Zostałem przy 8.5 z powodu funkcji udostępniania folderów [która zniknęła w późniejszych wydaniach - red.]. Wprowadźcie ją i będę zadowolony. Jeśli nie - pozwólcie mi wciąż korzystać z 8.5".

Dołącz do dyskusji
Bądź pierwszy i zostaw komentarz.