Poważna dziura w Linuksie

Większość dystrybucji Linuksa posiada lukę w systemie zabezpieczeń, pozwalającą hakerowi na przejęcie całkowitej kontroli nad systemem, ostrzegają przedstawiciele firmy Guardian Digital.

Przedstawiciele zajmującej się bezpieczeństwem komputerowym firmy Guardian Digital ostrzegają, że większość dystrybucji Linuksa posiada lukę w systemie zabezpieczeń, pozwalającą hakerowi na przejęcie całkowitej kontroli nad systemem.

"Dziura" znajduje się w bibliotece o nazwie zlib, która wykorzystywana jest przez system do dekompresji plików w takich aplikacjach, jak przeglądarka internetowa Mozilla, środowisko programistyczne GNU Compiler Collection, czy X11 - wykorzystywane przez niektóre wersje Linuksa do tworzenia okien.

Według specjalistów z Guardian Digital, biblioteka ta podatna jest na błąd przepełnienia bufora, pozwalający nieautoryzowanym użytkownikom na zdalne uruchomienie dowolnego kodu na atakowanym komputerze. W rezultacie haker może bezkarnie zainstalować np. konia trojańskiego czy inny "złośliwy" program.

Luka ta jest tym poważniejsza, że wiele aplikacji, mimo, że nie wykorzystuje zlib bezpośrednio, to odwołuje się do tej biblioteki, zwiększając w ten sposób zagrożenie.

Przedstawiciele Guardian Digital zalecają użytkownikom Linuksa kontakt z producentem wykorzystywanej przez siebie dystrybucji systemu.

Dołącz do dyskusji
Bądź pierwszy i zostaw komentarz.